WordPress 5.2.2 更新重视安全

保护您的站点安全

WordPress 5.2为您带来了更健壮的工具,让您识别并修正配置问题及致命错误。不管您是正在帮助客户的开发者,还是正在独立维护您的站点,这些工具都能在您需要时帮您获得正确的信息。

保持安全

站点健康检查

基于在5.1中引入的站点健康功能,这次发布加入了两个新页面,帮助您调试常见的配置问题。此发布还加入了让开发者显示调试信息给站点维护者的空间。 检查您的站点状态,并学习如何调试问题。

PHP错误保护

它具有更好的处理所谓的“死亡白屏”,这个功能主要是监测运行的插件或主题如有致命报错,将暂停插件或主题的运行,以确保网站的可访问;

服务所有人的改进

无障碍访问更新

此次的数个修改一同为使用屏幕阅读器及其他辅助技术的用户改善了内容感知及键盘导航流程。

新的仪表盘图标

十三个新图标包含了Instagram、BuddyPress的一篮子图标及旋转的地球图标来包容全球。在仪表盘中寻找他们吧!

其他更新

PHP版本更新

最低支持的PHP版本现在是5.6.20。从WordPress 5.2开始,主题和插件能够安全地利用命名空间、匿名函数及更多!

新的正文标签钩子

5.2导入了wp_body_open钩子,让主题能够在<body>元素的开头插入代码。

隐私更新

新的主题页模板、一个条件函数和两个CSS类让设计和自定义隐私政策页面变得更简单。

新的正文标签钩子

5.2导入了wp_body_open钩子,让主题能够在<body>元素的开头插入代码。

构建JavaScript

通过在@wordpress/scripts包中加入webpack和Babel配置,开发者不再需要考虑设置复杂的构建工具就能编写现代JavaScript。

发表评论

#